[4.4.2] Asus ZenFone 2 UI For MT6572

Custom ROM For MT6572



Asus ZenFone 2 UI is an aftermarket ROM for MT6572 devices. This ROM has full ZenFone UI and features. A Good ROM with good battery backup, smooth good for gaming.
An awesome ROM for MT6572, good RAM management and can be a permanent replacement for your stock ROM. Highly suggested to use this ROM for MT6572 because MT6572 has low specs and this ROM makes the most out of the specs and gives awesome performance

Huge and huge thanks to my friend Mark Bryan for porting this to MT6572 and making this ROM possible. Huge thanks to him.

This ROM has been powered by www.mtkroms.com

Give proper credits to the people mentioned below in the credits section. And remember to always post the link of this thread in your posts. Credits should be top priority. The credits must look like this :
"This ROM has been powered by http://mtkroms.com, the original ROM can be found at http://www.mtkroms.com/" This is a must, lot of hardwork has gone to make these ROMs




- ZenFone 2 UI
- ZenFone Features
- Stable
- No bugs
- Good RAM management
- Good battery backup
- Much more..........

- Delete boot.img in port ROM and use boot.img of Stock ROM
- Replace /etc/bluetooth,firmware,security,wifi from stock to port
- Replace libMali.so
- Edit Mount Points in /META-INF/com/google/android/

Note : If you do not have your stock updater-script follow the steps from step 18 to edit mount points without stock-updater-script : Edit mount points

- ZIP ROM
- Flash

To Fix Camera :
- libcamalgo.so
- libcameracustom.so
- libcamdrv
- camera.default.so

Join my FB Group for Updates on this ROM and more support :
https://www.facebook.com/groups/mtkroms/

- Mark Brayna - Porter of this ROM for MT6572
- Ajit Guraya
- Nameless Team
- Nova Team

43 comments:

  1. if you want port of kitkat to jelybean like where ?

    ReplyDelete
  2. Stuck in a bootloop...
    Boot.img is only 4KB, is this normal ?

    ReplyDelete
    Replies
    1. (I replaced the boot.img in the Port ROM by the one who is in my Stock ROM)

      Delete
  3. boot.img of the stock ROM : 6KB
    boot.img of the port ROM : 4KB
    I don't have to port kernel or something like that ?

    ReplyDelete
    Replies
    1. maybe the ZIP is not downloaded properly and is corrupted

      Delete
    2. Okay, I will re-download it.

      Delete
    3. The boot.img in the zip is 4KB, I will re-try to flash it, I follow all the steps in the porting guide.

      Delete
  4. Okay, it work this time, apparently the zip was corrupted.
    Thanks very much and good continuation.

    ReplyDelete
  5. Installation Aborted Can you please help me with this one?

    ReplyDelete
    Replies
    1. you have either messed up the updater-script or there is something wrong with the recovery

      Delete
  6. Thanks for that, I will try again to edit the mount points for this one.

    ReplyDelete
  7. Hi can you please help me with this? I am really interested in this rom but i will got the error installation aborted. I followed all the instruction but please help me to clarify this one. Should I be using the ZIP Folder that I have downloaded and then copy the necessary files from my Stock_ROM? e.g etc/bluetooth (From Stock, I will paste it to the Port ROM?) And then also I am confused with the mount points. I just copied the META-INFO from my Stock and then paste it to the Port ROM, zip the rom and flash. Am I correct? Thanks in Advance.

    ReplyDelete
    Replies
    1. yes the first part is correct. No, dont replace META-INF the guide is in the post on how to edit mount points

      Delete
    2. Thanks for quick reply. I check on my blocks info using the MTK Droid Setup and found out that there are 3 lines but on the META-INFO of the Port ROM, there are only two.

      PORT ROM:
      format("ext4", "EMMC", "/dev/block/mmcblk0p4", "0", "/system");
      mount("ext4", "EMMC", "/dev/block/mmcblk0p4", "/system");

      Blocks INFO:
      mmcblk0p4 /system
      mmcblk0p5 /cache
      mmcblk0p6 /data

      Please help me on how i can edit that one. Sorry but im really confused. I hope you can help me.

      Thanks A Lot!



      Im sorry but im really getting confused. This is my first time porting.

      Delete
    3. *it's common sense* all you need to do is change the number according to the number assigned to the particular partition. Why the heck don't people understand such a basic concept. Don't ask me questions regarding mount points again

      Delete
    4. Well, I guess this will be a bit confusing for "first timers". Thanks for the help though. And dont worry I will not bother you again. Great ROM! :)

      Delete
    5. when I got into custom rom porting after using IOS for my whole life until now, it took me 10 seconds to understand it and I am not lying

      Delete
  8. i got this errorand i dont have sound
    the process android.process.media has stopped
    i try with replace this file libaudio.primary.default.so but not fix
    how can fix that ?

    ReplyDelete
    Replies
    1. got the same problem here, trying to figure it out as well, no phone sound but there is sound in the headphones. had trouble getting gps lock as well.
      wifi and bluetooth, camera are working fine.

      Delete
    2. replace libaudio.primary.default.so

      Delete
    3. I replaced few others audio libs as well, got it working and replaced gps libs files too. now gets located easily.
      but there is some strange script or I can't figure it out right now, my internal storage is gone(hidden I suppose), and extsd card is showing as internal storage.
      might be an issue from my side, will update when get it sorted out.

      Delete
    4. there was no swap added to the "original ZenFOne UI ROM" maybe the dev who ported to MT6572 from my build must have added it. I will talk to him

      Delete
    5. also you can try this : replace vold and sdcard from /bin and replace storage_list.xml from stock to port framework-res.apk using WinZIP

      Delete
    6. Ok, I got it working, but winzip is a bad idea, if anyone else get this trouble, you will have to use apkmultitools set up environment and then edit, otherwise the systemui will stop, and would result in unstable rom. anyways thanks for the troubleshoot, it's a pretty much stable rom, my first try with an mtk device. success!!

      apart from everything, I found one bug, the home button is not working in this rom (would not do anything) and I can't get to the recent menu by pressing the back(hardware)button.

      although I don't like kingo root, and had trouble with certain apps that I prefer, had to clean them as well and successfully replace my superuser.

      apart from this I have managed to port your rom to a device which has no custom rom available anywhere on the internet. all thanks to you and all the devs.

      Delete
    7. yes it is always recommended to use apktool and the decompile and make changes and recompile but for basic users using WinRar works and no your argument about it being wrong is invalid. For CM 12.1 I always suggested people to use WinZIP to fix storage issues and it works and you can't say it is by luck

      Delete
    8. as for the buttons, delete /usr folder in port and use usr folder of stock

      Delete
    9. Well thank you for everything. You are doing an awesome job. it's a first time I have came across such a website that offers so much. my first experience here is better than being a senior member of xda, your help to the community is commendable, to the point and fast. Bless you.

      Delete
    10. thank you, I really appreciate it

      Delete
  9. i can't flash this rom just say installation aborted can you help me? am i doing something wrong? I already edited the mount point from script-update

    ReplyDelete
    Replies
    1. either you messed up updater-script or your recovery has issues and please don't question me saying i used to flash ROMs and this that. If I say it's problem in recovery then it's a problem in recovery unless you messed up the updater-script

      Delete
  10. android.process.media has stopped
    can fix that ?

    ReplyDelete
    Replies
    1. go to settings ->apps -> all-> and clear data on contact and contact storage in app manager. This will fix the problem.
      But... Your data for contacts will be wiped away. So remember to BACKUP!
      And if still not fixed replace soundfx folder from stock to port

      Delete
  11. i stuck at black screen after boot img....how to fix it

    ReplyDelete
  12. Ok, I replaced the etc/recovery.fstab which had your device mount points from my stock recovery.fstab. didn't made much difference(although the files had different mount points). I could see my internal storage in recovery mode, but when on this rom, it is somehow messing up the mount points and only shows my external drive(although it's good for devices having lesser internal space to swap it with the external card.). but I need my internal intact so where is this swap happening and where is the internal drive gone? what part I am missing?

    got rid of all the init.d scripts as well. any clue?

    ReplyDelete
  13. Keeps soft rebooting automatically when the battery is low arount 18% and wont move pass the boot logo until I remove the charger when I try to turn it on.... how to fix?

    ReplyDelete
    Replies
    1. i too got same pblm... when i connect to charger or sometimes when i lock d mobile.... it automatically switch of... ne need to remove battery nd put again to start mobile again.... Ajit plz help solve this pblm bro

      Delete

Powered by Blogger.